using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=\""textbkStyle\"">Renewal/Expiration Date:\s*<div class=\""responseText\"">\s*(\d{2}/\d{2}/\d{4})\s*</div>\s*</div>";
string input = @" <div class=""textbkStyle"">Renewal/Expiration Date:
<div class=""responseText"">
01/01/2019
</div>
</div>
<div class=""textbkStyle"">Renewal/Expiration Date:
<div class=""responseText"">
NOT AVAILABLE
</div>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}