import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\\\"textbkStyle\\\">Renewal/Expiration Date:\\s*<div class=\\\"responseText\\\">\\s*(\\d{2}/\\d{2}/\\d{4})\\s*</div>\\s*</div>";
final String string = " <div class=\"textbkStyle\">Renewal/Expiration Date:\n"
+ " <div class=\"responseText\">\n\n\n"
+ " 01/01/2019\n\n"
+ " </div>\n"
+ " </div>\n\n"
+ "<div class=\"textbkStyle\">Renewal/Expiration Date:\n"
+ " <div class=\"responseText\">\n\n\n"
+ " NOT AVAILABLE\n\n"
+ " </div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}