using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})";
string input = @"3
1000
2000
2018
2019
2020
2021
2100
2800
3001
4001
4000
7044
4444
9999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}