import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})";
final String string = "3\n"
+ "1000\n"
+ "2000\n"
+ "2018\n"
+ "2019\n"
+ "2020\n"
+ "2021\n"
+ "2100\n"
+ "2800\n"
+ "3001\n"
+ "4001\n"
+ "4000\n"
+ "7044\n"
+ "4444\n"
+ "9999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}