$re = '/(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})/m';
$str = '3
1000
2000
2018
2019
2020
2021
2100
2800
3001
4001
4000
7044
4444
9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);