package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<datetime1>\d+\/\d+\/\d+\s+\d+:\d+:\d+)\s+(?<field1>\d+)\s+(?<field2>\d+)\s+(?<field3>\d+)\s+(?<field4>\d+)\s+(?<field5>\d+)\s+(?<field6>\d+)\s+(?<field7>\S+)\s+(?<datetime2>\d+-\d+-\d+\s+\d+:\d+:\d+)`)
var str = `18/06/28 14:12:07 250 219561 711914 72864 0 784778 - 18-06-28 14:08:43`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}