re = /^(?<datetime1>\d+\/\d+\/\d+\s+\d+:\d+:\d+)\s+(?<field1>\d+)\s+(?<field2>\d+)\s+(?<field3>\d+)\s+(?<field4>\d+)\s+(?<field5>\d+)\s+(?<field6>\d+)\s+(?<field7>\S+)\s+(?<datetime2>\d+-\d+-\d+\s+\d+:\d+:\d+)/m
str = '18/06/28 14:12:07 250 219561 711914 72864 0 784778 - 18-06-28 14:08:43'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end