const regex = /^(?<datetime1>\d+\/\d+\/\d+\s+\d+:\d+:\d+)\s+(?<field1>\d+)\s+(?<field2>\d+)\s+(?<field3>\d+)\s+(?<field4>\d+)\s+(?<field5>\d+)\s+(?<field6>\d+)\s+(?<field7>\S+)\s+(?<datetime2>\d+-\d+-\d+\s+\d+:\d+:\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<datetime1>\\d+\\\/\\d+\\\/\\d+\\s+\\d+:\\d+:\\d+)\\s+(?<field1>\\d+)\\s+(?<field2>\\d+)\\s+(?<field3>\\d+)\\s+(?<field4>\\d+)\\s+(?<field5>\\d+)\\s+(?<field6>\\d+)\\s+(?<field7>\\S+)\\s+(?<datetime2>\\d+-\\d+-\\d+\\s+\\d+:\\d+:\\d+)', 'gm')
const str = `18/06/28 14:12:07 250 219561 711914 72864 0 784778 - 18-06-28 14:08:43`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}