import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<datetime1>\\d+\\/\\d+\\/\\d+\\s+\\d+:\\d+:\\d+)\\s+(?<field1>\\d+)\\s+(?<field2>\\d+)\\s+(?<field3>\\d+)\\s+(?<field4>\\d+)\\s+(?<field5>\\d+)\\s+(?<field6>\\d+)\\s+(?<field7>\\S+)\\s+(?<datetime2>\\d+-\\d+-\\d+\\s+\\d+:\\d+:\\d+)";
final String string = "18/06/28 14:12:07 250 219561 711914 72864 0 784778 - 18-06-28 14:08:43";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}