const regex = new RegExp('(?<=start)((\\".*?\\")(,\\s*)?)*', 'gm')
const str = `Пример 1 (здесь все ок):
start"content"
Пример 2 ("content" должны подсвечиваться в отдельную от запятых группу):
start"content", "content content", "content content", "content"
Пример 3 (здесь все ок):
start"content", start"content",start"content content", start"content"
Пример 4 (не должно подсвечиваться т.к. нет начального условия):
"content", "content content","content", "content"
Другое:
(,?\\s*)
(?<=start)((\\".*?\\")(,\\s*)?)*
(?<=start)(\\".*?\\"),?\\s*((\\".*?\\"),?\\s*)*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}