$re = '/(?<=start)((\".*?\")(,\s*)?)*/m';
$str = 'Пример 1 (здесь все ок):
start"content"
Пример 2 ("content" должны подсвечиваться в отдельную от запятых группу):
start"content", "content content", "content content", "content"
Пример 3 (здесь все ок):
start"content", start"content",start"content content", start"content"
Пример 4 (не должно подсвечиваться т.к. нет начального условия):
"content", "content content","content", "content"
Другое:
(,?\\s*)
(?<=start)((\\".*?\\")(,\\s*)?)*
(?<=start)(\\".*?\\"),?\\s*((\\".*?\\"),?\\s*)*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);