# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=start)((\".*?\")(,\s*)?)*"
test_str = ("Пример 1 (здесь все ок):\n"
"start\"content\"\n\n"
"Пример 2 (\"content\" должны подсвечиваться в отдельную от запятых группу):\n"
"start\"content\", \"content content\", \"content content\", \"content\"\n\n"
"Пример 3 (здесь все ок):\n"
"start\"content\", start\"content\",start\"content content\", start\"content\"\n\n"
"Пример 4 (не должно подсвечиваться т.к. нет начального условия):\n"
"\"content\", \"content content\",\"content\", \"content\"\n\n\n"
"Другое:\n"
"(,?\\s*)\n"
"(?<=start)((\\\".*?\\\")(,\\s*)?)*\n"
"(?<=start)(\\\".*?\\\"),?\\s*((\\\".*?\\\"),?\\s*)*")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.