using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\.([^.]*\.[^.]*)$";
string substitution = @"$1";
string input = @"23.456.78.910.abcdefgh";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}