$re = '/.*\.([^.]*\.[^.]*)$/m';
$str = '23.456.78.910.abcdefgh';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;