use strict;
my $str = '23.456.78.910.abcdefgh';
my $regex = qr/.*\.([^.]*\.[^.]*)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";