using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?([^ ]+@.+?\..+?:.+?)$";
string substitution = @"$1\n";
string input = @"Name: Test1 Test1
Address: 11 Test Road
Country : Test1
Post Code: abc111
EmailPass : test_111@hotmail.com:password111$£*!
Name: Test2 Test2
Address: 22 Test Road
Country : Test2
Post Code: abc222
EmailPass : test_222@gmail.com:password222$£*!";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}