$re = '/.*?([^ ]+@.+?\..+?:.+?)$/ms';
$str = 'Name: Test1 Test1
Address: 11 Test Road
Country : Test1
Post Code: abc111
EmailPass : test_111@hotmail.com:password111$£*!
Name: Test2 Test2
Address: 22 Test Road
Country : Test2
Post Code: abc222
EmailPass : test_222@gmail.com:password222$£*!';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;