// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms).*?([^ ]+@.+?\..+?:.+?)$").unwrap();
let string = "Name: Test1 Test1
Address: 11 Test Road
Country : Test1
Post Code: abc111
EmailPass : test_111@hotmail.com:password111$£*!
Name: Test2 Test2
Address: 22 Test Road
Country : Test2
Post Code: abc222
EmailPass : test_222@gmail.com:password222$£*!";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}