const regex = /.*?([^ ]+@.+?\..+?:.+?)$/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?([^ ]+@.+?\\..+?:.+?)$', 'gms')
const str = `Name: Test1 Test1
Address: 11 Test Road
Country : Test1
Post Code: abc111
EmailPass : test_111@hotmail.com:password111\$£*!
Name: Test2 Test2
Address: 22 Test Road
Country : Test2
Post Code: abc222
EmailPass : test_222@gmail.com:password222\$£*!`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);