import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]([a-z]|[A-Z])*[\\.]*(\\s)*([a-z]|[A-Z])*)[,]";
final String string = "John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
+ "John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
+ "John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
+ "Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler\n"
+ "Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler\n"
+ "Drama, Sci Fi, TV Show, Action\n"
+ "Drama, Action, HORROR, Adventure\n"
+ "Thriller, Mystery, Comedy\n"
+ "Comedy Romance, Action Comedy, CRIME, Sci Fi\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}