$re = '/([A-Z]([a-z]|[A-Z])*[\.]*(\s)*([a-z]|[A-Z])*)[,]/m';
$str = 'John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
Michael Jordan, Shaquile O\'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Michael Jordan, Shaquile O\'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Drama, Sci Fi, TV Show, Action
Drama, Action, HORROR, Adventure
Thriller, Mystery, Comedy
Comedy Romance, Action Comedy, CRIME, Sci Fi
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);