import re
regex = re.compile(r"([A-Z]([a-z]|[A-Z])*[\.]*(\s)*([a-z]|[A-Z])*)[,]", flags=re.MULTILINE)
test_str = ("John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
"John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
"John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson\n"
"Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler\n"
"Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler\n"
"Drama, Sci Fi, TV Show, Action\n"
"Drama, Action, HORROR, Adventure\n"
"Thriller, Mystery, Comedy\n"
"Comedy Romance, Action Comedy, CRIME, Sci Fi\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")