// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]([a-z]|[A-Z])*[\.]*(\s)*([a-z]|[A-Z])*)[,]").unwrap();
let string = "John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
John Smith, Maryjane, Mary Jane, Neo, Morpheus, Mr. Anderson
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Michael Jordan, Shaquile O'Neal, Kobe Bryant, Katy Perry , Bonnie Tyler
Drama, Sci Fi, TV Show, Action
Drama, Action, HORROR, Adventure
Thriller, Mystery, Comedy
Comedy Romance, Action Comedy, CRIME, Sci Fi
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}