package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\d{1,3}\.){3}\d{1,3}) (\w+|-) (\w+|-) \[(.*?)\] \"(\w+) (.*?) (HTTP|HTTPS)\/([0-9].[0-9])\" ([0-9]+) ([0-9]+) \"(\w+|-)\" \"(.*?)\"`)
var str = `127.0.0.1 - Username [27/Feb/2019:11:52:23 +0100] "PROPFIND /path/to/awesome/stuff/ HTTP/1.1" 207 9228 "-" "Mozilla/5.0 (Windows)"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}