import Foundation
let pattern = #"((?:\d{1,3}\.){3}\d{1,3}) (\w+|-) (\w+|-) \[(.*?)\] \"(\w+) (.*?) (HTTP|HTTPS)\/([0-9].[0-9])\" ([0-9]+) ([0-9]+) \"(\w+|-)\" \"(.*?)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"127.0.0.1 - Username [27/Feb/2019:11:52:23 +0100] "PROPFIND /path/to/awesome/stuff/ HTTP/1.1" 207 9228 "-" "Mozilla/5.0 (Windows)""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)