import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\d{1,3}\\.){3}\\d{1,3}) (\\w+|-) (\\w+|-) \\[(.*?)\\] \\\"(\\w+) (.*?) (HTTP|HTTPS)\\/([0-9].[0-9])\\\" ([0-9]+) ([0-9]+) \\\"(\\w+|-)\\\" \\\"(.*?)\\\"";
final String string = "127.0.0.1 - Username [27/Feb/2019:11:52:23 +0100] \"PROPFIND /path/to/awesome/stuff/ HTTP/1.1\" 207 9228 \"-\" \"Mozilla/5.0 (Windows)\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}