const regex = new RegExp('((?:\\d{1,3}\\.){3}\\d{1,3}) (\\w+|-) (\\w+|-) \\[(.*?)\\] \\"(\\w+) (.*?) (HTTP|HTTPS)\\/([0-9].[0-9])\\" ([0-9]+) ([0-9]+) \\"(\\w+|-)\\" \\"(.*?)\\"', 'gm')
const str = `127.0.0.1 - Username [27/Feb/2019:11:52:23 +0100] "PROPFIND /path/to/awesome/stuff/ HTTP/1.1" 207 9228 "-" "Mozilla/5.0 (Windows)"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}