#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=too many request from ).*?(?=/32 in)"
Local $sString = "{"log":"2024-12-29 13:16:48,060 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T13:16:48.06064193Z"}" & @CRLF & _
"{"log":"2024-12-29 13:17:07,197 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T13:17:07.197643948Z"}" & @CRLF & _
"{"log":"2024-12-29 12:53:40,849 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T12:53:40.84964623Z"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")