import Foundation
let pattern = #"(?<=too many request from ).*?(?=/32 in)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"log":"2024-12-29 13:16:48,060 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T13:16:48.06064193Z"}
{"log":"2024-12-29 13:17:07,197 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T13:17:07.197643948Z"}
{"log":"2024-12-29 12:53:40,849 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\n","stream":"stderr","time":"2024-12-29T12:53:40.84964623Z"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)