# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=too many request from ).*?(?=/32 in)"
test_str = ("{\"log\":\"2024-12-29 13:16:48,060 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n\",\"stream\":\"stderr\",\"time\":\"2024-12-29T13:16:48.06064193Z\"}\n"
"{\"log\":\"2024-12-29 13:17:07,197 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n\",\"stream\":\"stderr\",\"time\":\"2024-12-29T13:17:07.197643948Z\"}\n"
"{\"log\":\"2024-12-29 12:53:40,849 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n\",\"stream\":\"stderr\",\"time\":\"2024-12-29T12:53:40.84964623Z\"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.