$re = '~(?<=too many request from ).*?(?=/32 in)~m';
$str = '{"log":"2024-12-29 13:16:48,060 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n","stream":"stderr","time":"2024-12-29T13:16:48.06064193Z"}
{"log":"2024-12-29 13:17:07,197 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n","stream":"stderr","time":"2024-12-29T13:17:07.197643948Z"}
{"log":"2024-12-29 12:53:40,849 ERROR:searx.botdetection.ip_limit: BLOCK: too many request from <HOST>/32 in SUSPICIOUS_IP_WINDOW (redirect to /)\\n","stream":"stderr","time":"2024-12-29T12:53:40.84964623Z"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);