using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+\.\d+|NA)(?:,\1)+\b";
string substitution = @"\1";
string input = @"2.752,2.752,2.752,2.752,2.752,2.752,2.752,2.911,2.911,3.555
2.999,2.999,2.999,2.752,2.752,2.752,2.752
1.34,1.34,1.34,1.55,1.55,1.55,1.55,1.55,1.55,1.55
1.56,1.56,1.56,1.55,1.55,1.55,1.55,NA,NA,NA,NA,1.34,1.34,1.34
NA,NA,NA,0.147,0.147,0.147,0.147,0.147,NA
0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}