use strict;
my $str = '2.752,2.752,2.752,2.752,2.752,2.752,2.752,2.911,2.911,3.555
2.999,2.999,2.999,2.752,2.752,2.752,2.752
1.34,1.34,1.34,1.55,1.55,1.55,1.55,1.55,1.55,1.55
1.56,1.56,1.56,1.55,1.55,1.55,1.55,NA,NA,NA,NA,1.34,1.34,1.34
NA,NA,NA,0.147,0.147,0.147,0.147,0.147,NA
0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146';
my $regex = qr/\b(\d+\.\d+|NA)(?:,\1)+\b/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";