# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(\d+\.\d+|NA)(?:,\1)+\b"
test_str = ("2.752,2.752,2.752,2.752,2.752,2.752,2.752,2.911,2.911,3.555\n"
"2.999,2.999,2.999,2.752,2.752,2.752,2.752\n"
"1.34,1.34,1.34,1.55,1.55,1.55,1.55,1.55,1.55,1.55\n"
"1.56,1.56,1.56,1.55,1.55,1.55,1.55,NA,NA,NA,NA,1.34,1.34,1.34\n"
"NA,NA,NA,0.147,0.147,0.147,0.147,0.147,NA\n"
"0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146,0.146")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.