# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)/ *\*.*?\* */"
test_str = ("{\n"
" CALLING_NBR = 1, / * nn svjfv ks;am scjv * /\n"
" CALLED_NBR = 2, / * ssvdsv * / \n"
" EVENT_BEGIN_TIME = 3, / * * / \n"
" DURATION = 4, / * dhuf bvhsbv sjkncjsv jsvnjsdbv \n"
" the value of rthe vbisu * / \n"
" BILLING_PREFIX = 5 ,\n"
" CALLING_CIRCLE_TYPE_ID = 6,\n\n"
" CALL_TYPE = 7, / * call type* / \n"
"CALLING_PREFIX = 8, / * calling e * / ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.