#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z]{2}\d{5,})"
Local $sString = "Jm37908" & @CRLF & _
"Za94025" & @CRLF & _
"Sw02834" & @CRLF & _
"Pt012345678" & @CRLF & _
"t-z12345" & @CRLF & _
"aA12345" & @CRLF & _
"x12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")