const regex = /([a-zA-Z]{2}\d{5,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]{2}\\d{5,})', 'gm')
const str = `Jm37908
Za94025
Sw02834
Pt012345678
t-z12345
aA12345
x12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}