using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]{2}\d{5,})";
string input = @"Jm37908
Za94025
Sw02834
Pt012345678
t-z12345
aA12345
x12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}