$re = '/([a-zA-Z]{2}\d{5,})/m';
$str = 'Jm37908
Za94025
Sw02834
Pt012345678
t-z12345
aA12345
x12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);