package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`src="([^"]+)"`)
var str = `<p>Тут текст <img alt="" src="https://nailsoftheday.com/upload/_images/images/26.jpg" style="height:437px; width:437px" /> произвольный текст</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}