$re = '/src="([^"]+)"/';
$str = '<p>Тут текст <img alt="" src="https://nailsoftheday.com/upload/_images/images/26.jpg" style="height:437px; width:437px" /> произвольный текст</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);