const regex = /src="([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="([^"]+)"', 'g')
const str = `<p>Тут текст <img alt="" src="https://nailsoftheday.com/upload/_images/images/26.jpg" style="height:437px; width:437px" /> произвольный текст</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}