import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=\"([^\"]+)\"";
final String string = "<p>Тут текст <img alt=\"\" src=\"https://nailsoftheday.com/upload/_images/images/26.jpg\" style=\"height:437px; width:437px\" /> произвольный текст</p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}