#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:(\w)(?=\w*+\W++(?=\w*\1)(\2?+\w)))++\W++\2\b"
Local $sString = "fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo" & @CRLF & _
"now we go with smart trams maps amps because declamations anecdotalism" & @CRLF & _
"reoccupation cornucopiate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")