import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(\\w)(?=\\w*+\\W++(?=\\w*\\1)(\\2?+\\w)))++\\W++\\2\\b";
final String string = "fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo\n"
+ "now we go with smart trams maps amps because declamations anecdotalism\n"
+ "reoccupation cornucopiate";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}