$re = '/\b(?:(\w)(?=\w*+\W++(?=\w*\1)(\2?+\w)))++\W++\2\b/';
$str = 'fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);