re = /\b(?:(\w)(?=\w*+\W++(?=\w*\1)(\2?+\w)))++\W++\2\b/
str = 'fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end