# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\/\/\S*)|[[:punct:]]+/\1/gi;t' <<< "This is a URL: https://test.com/ThisIsAURL !"