re = /(https?:\/\/\S*)|[[:punct:]]+/i
str = 'This is a URL: https://test.com/ThisIsAURL !'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result