use strict;
my $str = 'This is a URL: https://test.com/ThisIsAURL !';
my $regex = qr~(https?://\S*)|[[:punct:]]+~ip;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";